BETA

13th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [13/08/18 03:13 PM] with 'Major Outage'

Issue has been resolved at [13/08/18 03:14 PM]