BETA

15th March 2019

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [15/03/19 06:59 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [15/03/19 07:11 AM]