BETA

12th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [12/08/18 12:15 PM] with 'Major Outage'

Issue has been resolved at [12/08/18 12:16 PM]