BETA

15th March 2019

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [15/03/19 06:55 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [15/03/19 07:15 AM]