BETA

15th July 2016

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [15/07/16 02:14 PM] with 'Partial Outage'

Issue has been resolved at [15/07/16 02:15 PM]