BETA

12th August 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [12/08/18 07:13 AM] with 'Partial Outage'

Issue has been resolved at [12/08/18 07:27 AM]