BETA

13th April 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [13/04/17 02:09 PM] with 'Major Outage'

Issue has been resolved at [13/04/17 02:10 PM]