BETA

12th August 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [12/08/18 07:03 AM] with 'Major Outage'

Issue has been resolved at [12/08/18 07:05 AM]