BETA

11th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [11/08/18 03:01 PM] with 'Major Outage'

Issue has been resolved at [11/08/18 03:04 PM]