BETA

11th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [11/08/18 01:10 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [11/08/18 01:12 PM]