BETA

15th March 2019

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [15/03/19 03:45 AM] with 'Partial Outage'

Issue has been resolved at [15/03/19 03:47 AM]