BETA

11th August 2018

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [11/08/18 08:16 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [11/08/18 08:18 AM]