BETA

13th April 2017

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [13/04/17 10:25 AM] with 'Major Outage'

Issue has been resolved at [13/04/17 10:26 AM]