BETA

10th August 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [10/08/18 05:44 PM] with 'Partial Outage'

Issue has been resolved at [10/08/18 05:46 PM]