BETA

9th May 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [09/05/19 05:28 AM] with 'Partial Outage'

Issue has been resolved at [09/05/19 05:31 AM]