BETA

10th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [10/08/18 02:22 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [10/08/18 02:24 PM]