BETA

10th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [10/08/18 12:20 PM] with 'Partial Outage'

Issue has been resolved at [10/08/18 12:22 PM]