BETA

10th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [10/08/18 12:14 PM] with 'Major Outage'

Issue has been resolved at [10/08/18 12:18 PM]