BETA

10th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [10/08/18 11:54 AM] with 'Major Outage'

Issue has been resolved at [10/08/18 11:57 AM]