BETA

9th August 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [09/08/18 06:44 PM] with 'Partial Outage'

Issue has been resolved at [09/08/18 06:46 PM]