BETA

13th July 2016

Incoming SMS Issue observed for Incoming SMS across India

Identified at [13/07/16 02:28 AM] with 'Major Outage'

Issue has been resolved at [13/07/16 02:29 AM]