BETA

8th May 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [08/05/19 03:09 PM] with 'Partial Outage'

Issue has been resolved at [08/05/19 03:10 PM]