BETA

9th August 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [09/08/18 11:10 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [09/08/18 11:12 AM]