BETA

8th May 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [08/05/19 08:21 AM] with 'Partial Outage'

Issue has been resolved at [08/05/19 08:22 AM]