BETA

12th April 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [12/04/17 10:56 AM] with 'Major Outage'

Issue has been resolved at [12/04/17 10:57 AM]