BETA

12th April 2017

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [12/04/17 10:56 AM] with 'Partial Outage'

Issue has been resolved at [12/04/17 10:57 AM]