BETA

8th May 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [08/05/19 03:59 AM] with 'Major Outage'

Issue has been resolved at [08/05/19 04:01 AM]