BETA

8th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [08/08/18 12:45 PM] with 'Partial Outage'

Issue has been resolved at [08/08/18 12:48 PM]