BETA

7th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [07/08/18 04:10 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [07/08/18 04:12 PM]