BETA

11th April 2017

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [11/04/17 12:06 PM] with 'Major Outage'

Issue has been resolved at [11/04/17 12:07 PM]