BETA

7th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [07/08/18 01:33 PM] with 'Major Outage'

Issue has been resolved at [07/08/18 01:34 PM]