BETA

7th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [07/08/18 11:42 AM] with 'Partial Outage'

Issue has been resolved at [07/08/18 11:44 AM]