BETA

7th May 2019

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [07/05/19 11:05 PM] with 'Major Outage'

Issue has been resolved at [07/05/19 11:07 PM]