BETA

6th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [06/08/18 03:30 PM] with 'Partial Outage'

Issue has been resolved at [06/08/18 03:33 PM]