BETA

14th March 2019

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [14/03/19 09:59 PM] with 'Partial Outage'

Issue has been resolved at [14/03/19 10:00 PM]