BETA

11th April 2017

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [11/04/17 11:34 AM] with 'Major Outage'

Issue has been resolved at [11/04/17 11:35 AM]