BETA

6th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [06/08/18 11:43 AM] with 'Major Outage'

Issue has been resolved at [06/08/18 11:46 AM]