BETA

5th August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [05/08/18 04:45 PM] with 'Major Outage'

Issue has been resolved at [05/08/18 04:47 PM]