BETA

5th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [05/08/18 04:36 PM] with 'Partial Outage'

Issue has been resolved at [05/08/18 04:37 PM]