BETA

5th August 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [05/08/18 08:37 AM] with 'Major Outage'

Issue has been resolved at [05/08/18 08:38 AM]