BETA

4th August 2018

Karnataka Issue observed for 'Outgoing Calls' in Karnataka Region

Identified at [04/08/18 10:45 PM] with 'Partial Outage'

Issue has been resolved at [04/08/18 10:48 PM]