BETA

4th August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [04/08/18 12:13 PM] with 'Partial Outage'

Issue has been resolved at [04/08/18 12:16 PM]