BETA

11th April 2017

Outgoing SMS Issue observed for Outgoing SMS across India

Identified at [11/04/17 08:52 AM] with 'Partial Outage'

Issue has been resolved at [11/04/17 08:54 AM]