BETA

3rd August 2018

Delhi Issue observed for 'Outgoing Calls' in Delhi Region

Identified at [03/08/18 09:22 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/08/18 09:25 PM]