BETA

3rd August 2018

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [03/08/18 08:36 PM] with 'Partial Outage'

Issue has been resolved at [03/08/18 08:43 PM]