BETA

3rd August 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [03/08/18 05:53 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/08/18 05:54 PM]