BETA

3rd August 2018

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [03/08/18 01:26 PM] with 'Major Outage'

Issue has been resolved at [03/08/18 01:27 PM]