BETA

3rd August 2018

Chennai Issue observed for 'Outgoing Calls' in Chennai Region

Identified at [03/08/18 06:39 AM] with 'Major Outage'

Issue has been resolved at [03/08/18 06:42 AM]