BETA

2nd August 2018

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [02/08/18 06:01 PM] with 'Partial Outage'

Issue has been resolved at [02/08/18 06:02 PM]