BETA

2nd August 2018

Karnataka Issue observed for 'Incoming Calls' in Karnataka Region

Identified at [02/08/18 03:19 PM] with 'Partial Outage'

Issue has been resolved at [02/08/18 03:20 PM]